Support chat is down
Incident Report for Robin
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 15:20 EST
Investigating
We are experiencing an issue with our chat at the moment. Please bear with us as we investigate. We expect to be back up shortly. Thank you!
Posted Dec 06, 2024 - 15:10 EST
This incident affected: Dashboard and Mobile.