Android devices stuck updating
Incident Report for Robin
Resolved
The majority of devices have successfully received the patch and should be operating as expected. Our logs indicate that network issues may have prevented a handful of devices from updating to v3.0.0-14 successfully; reinstalling the app should fix this problem.

Thankfully the issue is exceedingly rare, and after hundreds of successful app updates, this is the first instance we’ve had with an Android release. Our team is updating existing safeguards to ensure that this will not happen again.
Posted over 1 year ago. Jan 11, 2018 - 15:36 EST
Monitoring
We're starting to roll out a patch, v3.0.0-14, which will force any devices still stuck in the "updating" state to update successfully. We're currently monitoring the roll out, and expect all devices to receive the update by 1:00am UTC or 8:00pm EST. If your device is experiencing issues receiving the patch, a restart of the app should fix the problem.
Posted over 1 year ago. Jan 10, 2018 - 17:35 EST
Investigating
Last night, all Rooms apps running on Android devices received an automatic update, v3.0.0-13. The update was interrupted for a handful of devices, leading them to get stuck midway through the update. The existing safeguards for rolling back bad deployments did not complete successfully for 51% of impacted devices, leading to this issue. We expect a fix for impacted devices later today. If you need an immediate resolution, a reinstall of the app will fix the problem.

We're currently investigating the reason why the update was interrupted, why some devices got stuck in the update loop. Once we identify the reason, we can share more about remediation going forward.
Posted over 1 year ago. Jan 10, 2018 - 11:14 EST