Increased API latency
Incident Report for Robin
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 13:05 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2020 - 10:33 EDT
Investigating
We are currently investigating this issue.
Posted Jul 23, 2020 - 09:58 EDT
This incident affected: Dashboard, API, Status Boards, and Add-in.