Robin Analytics Experiencing data retrieval problems
Incident Report for Robin
Resolved
This incident has been resolved.
Posted 27 days ago. Feb 22, 2019 - 17:32 EST
Investigating
We are currently investigating this issue.
Posted 27 days ago. Feb 22, 2019 - 14:03 EST
This incident affected: Analytics.