Verification is currently underway for the maintenance items.
Posted Dec 20, 2025 - 09:21 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 19, 2025 - 23:34 EST
Scheduled
We will be performing scheduled US datacenter maintenance over the weekend during an expanded window. This work is part of an important infrastructure update designed to improve overall performance and reliability. During this time, some services may experience brief or intermittent interruptions.
Our team will be actively monitoring the environment to keep any impact minimal.
Posted Dec 10, 2025 - 15:19 EST
This scheduled maintenance affected: Platform (API, Email Notifications, Analytics), Dashboard, Mobile, Add-in, Room Displays, Status Boards, Infrastructure (AWS US East, AWS US West, DNS - Cloudflare, Billing), Calendar Syncing (Syncing Service, Google Apps Calendar), Bots (Slack), and Support (Live Chat).