Problems editing calendar events
Incident Report for Robin
Resolved
This incident has been resolved.
Posted 11 months ago. May 31, 2018 - 19:28 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. May 31, 2018 - 19:16 EDT
Update
The issue is currently affecting some Microsoft calendars. Google calendars should be working normally. A fix is currently being deployed.
Posted 11 months ago. May 31, 2018 - 19:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 31, 2018 - 18:50 EDT
Investigating
We're investigating reports of certain accounts unable to edit calendar events.
Posted 11 months ago. May 31, 2018 - 18:29 EDT
This incident affected: API.