Extension errors
Incident Report for Robin
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 16, 2019 - 14:31 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Aug 16, 2019 - 14:28 EDT
Investigating
We're currently investigating issues connecting to google extension & office add-in.
Posted about 1 month ago. Aug 16, 2019 - 14:27 EDT