Google Calendar Push Notification Service Outage
Incident Report for Robin
Resolved
We haven't seen any errors from Google Calendar for the last 60 minutes and are marking this issue as resolved. We'll continue to monitor for this throughout today and will re-open this incident if anything changes.
Posted 10 months ago. Jun 20, 2018 - 11:10 EDT
Update
Google has begun rolling out a fix and stated that it may take two days to propagate to all users. We're already seeing substantially less errors versus the same time yesterday and are optimistic that service is mostly restored.
Posted 10 months ago. Jun 20, 2018 - 10:47 EDT
Monitoring
Google has acknowledged the issue and appears to be addressing it shortly: https://issuetracker.google.com/issues/110373170#comment20
Posted 10 months ago. Jun 20, 2018 - 08:11 EDT
Identified
Existing notification channels seem to be working fine and the issue seems to be limited to creating new notification channels. This means that syncing may not initially work for newly added calendars. We're continuing to monitor the situation and a thread on the Google issue tracker can be found here: https://issuetracker.google.com/issues/110373170
Posted 10 months ago. Jun 19, 2018 - 16:22 EDT
Investigating
We're seeing elevated errors from Google Calendar relating to calendar subscriptions / push notifications. Robin uses these notifications to sync a calendar when a change is made. Initial investigation seems to indicate that this service disruption is for all users of the Google Calendar API using the push notification feature.

Customers that use Google Calendar may notice calendars not syncing to Robin as expected. We'll continue to update this incident as we learn more.
Posted 10 months ago. Jun 19, 2018 - 10:47 EDT
This incident affected: Calendar Syncing (Google Apps Calendar).