Robin Insights Experiencing data retrieval problems
Incident Report for Robin
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 26, 2019 - 13:28 EST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Feb 26, 2019 - 09:15 EST
This incident affected: Analytics.